Issue #16469 has been reported by sue445 (Go Sueyoshi).

----------------------------------------
Bug #16469: Wrong warning message at `URI.encode` and `URI.decode`
https://bugs.ruby-lang.org/issues/16469

* Author: sue445 (Go Sueyoshi)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-darwin17], ruby 2.8.0dev (2020-01-01T06:06:19Z master afd3f64f8c) [x86_64-darwin17]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
# Sample code
``` ruby
enc_uri = URI.encode("http://example.com/?a=\11\15")
URI.decode(enc_uri)
```

# Actual
```ruby
irb(main):005:0> enc_uri = URI.encode("http://example.com/?a=\11\15")
(irb):3: warning: URI.escape is obsolete

irb(main):006:0> URI.decode(enc_uri)
(irb):6: warning: URI.unescape is obsolete
=> "http://example.com/?a=\t\r"
```

# Expected
Print `warning: URI.encode is obsolete` and `warning: URI.decode is obsolete` . (or no warnings)




-- 
https://bugs.ruby-lang.org/