Issue #16405 has been updated by hsbt (Hiroshi SHIBATA).


Rails も 4.0 と Ruby 同様にサポートされていないバージョンなので、5.2 ないし 6.0 で合わせて再現するかを確認することをお勧めします。

----------------------------------------
Bug #16405: [BUG] Segmentation fault at 0x007ffeef650000
https://bugs.ruby-lang.org/issues/16405#change-82990

* Author: nakoshi_noriaki (名越 仁昭)
* Status: Third Party's Issue
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: ruby 2.1.10p492 (2016-04-01 revision 54464) [x86_64-darwin19.0]
* Backport: 2.5: UNKNOWN, 2.6: UNKNOWN
----------------------------------------
RailsからMySQL接続するさいエラーが出ます。
Googleで調べてもわからなかったため、ご連絡差し上げた次第でございまう。
ご確認していただけると非常に助かります。

OS:Mac Catalia 1.15.1
ruby -v:ruby 2.1.10p492 (2016-04-01 revision 54464) [x86_64-darwin19.0]
rails -v :Rails 4.0.0
mysql --version:mysql  Ver 14.14 Distrib 5.6.46, for osx10.15 (x86_64) using  EditLine wrapper

bundle exec rake db:migrate 

で添付ファイルのエラーが出ます。

~/Library/Logs/CrashReporterにはファイルがありませんでした。

---Files--------------------------------
migrateのエラー.txt (485 KB)
DiagnosticReportsのエラー.txt (1.85 KB)


-- 
https://bugs.ruby-lang.org/