Issue #13998 has been updated by nagachika (Tomoyuki Chikanaga).

Backport changed from 2.3: REQUIRED, 2.4: REQUIRED to 2.3: REQUIRED, 2.4: DONE

ruby_2_4 r62691 merged revision(s) 60160.

----------------------------------------
Bug #13998: BOM disables "mismatched indentations" warning
https://bugs.ruby-lang.org/issues/13998#change-70836

* Author: ko1 (Koichi Sasada)
* Status: Closed
* Priority: Normal
* Assignee: nobu (Nobuyoshi Nakada)
* Target version: 2.5
* ruby -v: Ruby 2.3 and later.
* Backport: 2.3: REQUIRED, 2.4: DONE
----------------------------------------
`ruby -w` doesn't show "mismatched indentations" when scripts containing BOM.
This issue occurs on Ruby 2.3 and later.



-- 
https://bugs.ruby-lang.org/