Issue #14040 has been reported by znz (Kazuhiro NISHIYAMA).

----------------------------------------
Feature #14040: deprecate HTTP.version_1_2
https://bugs.ruby-lang.org/issues/14040

* Author: znz (Kazuhiro NISHIYAMA)
* Status: Open
* Priority: Normal
* Assignee: 
* Target version: 
----------------------------------------
r60311 をみて、`Net::HTTP#min_version/max_version` って長い間 1.2 になってから変わっていない net/http 自体のバージョンと紛らわしいと思ったので、 `Net::HTTP.version_1_2` などは deprecated にして、将来のバージョン (ruby 3.0?) では削除してしまうのはどうでしょうか?

(ついでに書いてしまうと HTTP 自体のバージョンとも紛らわしいので `Net::HTTP#min_ssl_version/max_ssl_version` のような名前の方が良いかもしれないと思いました。)



-- 
https://bugs.ruby-lang.org/