Issue #13899 has been reported by usa (Usaku NAKAMURA).

----------------------------------------
Bug #13899: Ruby 2.4.2 and 2.3.5 cannot link with libgmp nor jemalloc
https://bugs.ruby-lang.org/issues/13899

* Author: usa (Usaku NAKAMURA)
* Status: Closed
* Priority: Normal
* Assignee: 
* Target version: 
* ruby -v: 2.4.2, 2.3.2
* Backport: 
----------------------------------------
The released package of Ruby 2.4.2 and 2.3.5 cannot link with libgmp nor jemalloc.
Then, I provide the fixes.

for Ruby 2.4.2:
  a. Override `configure` file in your package by `configure-2.4.2`, and run `configure`.
  b. Or, apply the patch `configure-2.4.2.diff`, and run `configure`.

for Ruby 2.3.5:
  a. Override `configure` file in your package by `configure-2.3.5`, and run `configure`.
  b. Or, apply the patch `configure-2.3.5.diff`, and run `configure`.


---Files--------------------------------
configure-2.3.5 (657 KB)
configure-2.3.5.diff (1.46 KB)
configure-2.4.2 (719 KB)
configure-2.4.2.diff (1.46 KB)


-- 
https://bugs.ruby-lang.org/