Issue #12742 has been updated by Usaku NAKAMURA.

Backport changed from 2.1: DONTNEED, 2.2: REQUIRED, 2.3: DONE to 2.1: DONTNEED, 2.2: DONE, 2.3: DONE

ruby_2_2 r56309 merged revision(s) 56117.
ruby 2.2 doesn't warn deprecated constants, then we don't have to (or, can't) backport r56118.

----------------------------------------
Bug #12742: backport r56117 (fix private constant message) and r56118 (fix deprecated constant message)
https://bugs.ruby-lang.org/issues/12742#change-60733

* Author: Tomoyuki Chikanaga
* Status: Closed
* Priority: Normal
* Assignee: 
* ruby -v: -
* Backport: 2.1: DONTNEED, 2.2: DONE, 2.3: DONE
----------------------------------------
バックポート管理用チケットです。



-- 
https://bugs.ruby-lang.org/