Issue #9706 has been updated by Usaku NAKAMURA.

Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED to 2.0.0: DONE, 2.1: REQUIRED

Backported into ruby_2_0_0 at r46152.

----------------------------------------
Bug #9706: Date#<=> should use #< method(fixed at r45520)
https://bugs.ruby-lang.org/issues/9706#change-46880

* Author: Tomoyuki Chikanaga
* Status: Closed
* Priority: Normal
* Assignee: 
* Category: ext
* Target version: current: 2.2.0
* ruby -v: -
* Backport: 2.0.0: DONE, 2.1: REQUIRED
----------------------------------------
Date#<=> で #< メソッドを使って比較するようにする修正です。
trunk では r45520 で修正済みで、バックポート管理用にチケット化します。



-- 
https://bugs.ruby-lang.org/