artonです。

trunk(r39202)で試してみました。
以下のように、i386-msvcr100がsitearchdirとなり、(当然ですが一応試した)
setup.rbでインストールしたsoがrequireできることを確認しました。

どうもありがとうございます。

----
2.0.0/i386-mswin32_100/2013-02-11

RbConfig::CONFIG
sitearchdir=/lib/ruby/site_ruby/2.0.0/i386-msvcr100
sitearchlibdir=/lib/i386-msvcr100

$:
/lib/ruby/site_ruby/2.0.0
/lib/ruby/site_ruby/2.0.0/i386-msvcr100
/lib/ruby/site_ruby
/lib/ruby/vendor_ruby/2.0.0
/lib/ruby/vendor_ruby/2.0.0/i386-msvcr100
/lib/ruby/vendor_ruby
/lib/ruby/2.0.0
/lib/ruby/2.0.0/i386-mswin32_100

-- 
arton <artonx / yahoo.co.jp>