> Q. 拡張ライブラリは利用していますでしょうか.

 nokogiri (1.5.0)
 sqlite3 (1.3.5)
 tokyocabinet (1.29)

を使っています。

念のため require しているのを全部書くと、
  cgi, csv, date, httpclient, net/http, nkf, nokogiri, optparse, pp,
  rubygems, set, sqlite3, thread, tokyocabinet, uri
です。

> Q. 再現プログラムを頂くことはできませんでしょうか.

すみません、こっちはすぐには難しい感じです。
 業務要件詰め込んだスクリプト × 数十GBのテキストファイル × 数十時間の連続動作
でようやく3回発生するくらいの頻度なので、
どのあたりのコードがクサイのかも絞り込めておりません…。