Issue #7000 has been reported by sho-h (Sho Hashimoto).

----------------------------------------
Bug #7000: Tk::Scrollable の include が成功しない?
https://bugs.ruby-lang.org/issues/7000

Author: sho-h (Sho Hashimoto)
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 
ruby -v: ruby 2.0.0dev (2012-09-07 trunk 36920) [x86_64-linux]


るりまを修正していた際に気付いたのですが、以下の include Scrollable している点はすべてうまく動作しないのではないでしょうか。require に失敗する気がします。

  $ grep Scrollable **/*
  ...
  ext/tk/lib/tkextlib/bwidget/spinbox.rb:  include Scrollable
  ext/tk/lib/tkextlib/bwidget/tree.rb:  include Scrollable
  ext/tk/lib/tkextlib/tcllib/autoscroll.rb:  module Scrollable
  ext/tk/lib/tkextlib/tcllib/tablelist_core.rb:  include Scrollable
  ext/tk/lib/tkextlib/tile/treeview.rb:  include Scrollable
  ext/tk/lib/tkextlib/tkHTML/htmlwidget.rb:  include Scrollable
  ext/tk/lib/tkextlib/tktable/tktable.rb:  include Scrollable
  ext/tk/lib/tkextlib/treectrl/tktreectrl.rb:  include Scrollable

Tk::Scrollable が存在するようなので合っていればこれに書き換えるべきなのかもしれません。
(tk まわりに詳しくないため、動作確認はできていません。すみません)



-- 
http://bugs.ruby-lang.org/