2012年6月26日 5:15 SASADA Koichi <ko1 / atdot.net>:
> (2012/06/26 5:07), Tanaka Akira wrote:
>>
>> 名前ですが、Thread.interruptable_at(:blocking) とかはどうかなぁ。
>
>  これだと,例外クラスを指定する場合,
>
>    Thread.interruptable_at(:blocking, TimeoutError)
>
> みたいに書くの?

そうなりますね。

>  確かに,仰るとおりです.寝ぼけた頭では,とりあえず
>
> (1) 「実装上はそこでは例外は起きない」ことを仕様にする
> (2) ensure に細工する(あまりやりたくない)
> (3) 利用者が immediate にしない
>
> が考えられると思います.どれがいいでしょう.または,他の選択肢はあるで
> しょうか.

kosaki さんの「1行目で blocking_interruptible にして二度と変えない。」とか、
私の「(100% コンパチブルという話を) 尊重しないなら、
遅延させるという選択肢もあるかもしれません。」
とかが、そのへんに対する表明なんじゃないですかねぇ。

また、昔ので Thread.delay_interrupt の逆がないというのも、
そうだったのかもしれません。

kosaki さんは (3) で、
私はどちらかというとデフォルトを変えてしまうほうに向いているかな。
-- 
[田中 哲][たなか あきら][Tanaka Akira]