(2012/06/21 9:15), Yugui wrote:
> 
> * rb_eval_string_with_filename(VALUE string, VALUE fname);
> * rb_eval_string_with_filename_protect(VALUE string, VALUE fname, int* state);
> を追加、
> 
> という提案をします。異論が無ければあとでコミットしますが、特に追加する関数の名前について何かご意見(もっと良い名前)は無いでしょうか。

 いろいろ考えてたんですが,

rb_eval_string(const char *str)
を
rb_eval_string(const char *str, ...)
にしちゃうのはやっぱやり過ぎですかねぇ.第二引数があれば filename と考え
る,みたいな.

もう少し考えさせて下さい.

-- 
// SASADA Koichi at atdot dot net