Issue #5861 has been updated by Nobuyoshi Nakada.


Yui NARUSE wrote:
> ??????????????????????????????????????????String#version_compare ???追??????????????????
> "2.6.18".version_compare("2.6.3") #=> 1
> ????使??????????

Gem::Version.new("2.6.18")<=>Gem::Version.new("2.6.3") ????????????????????????????????????

----------------------------------------
Feature #5861: String#version_compare
https://bugs.ruby-lang.org/issues/5861

Author: Yui NARUSE
Status: Assigned
Priority: Normal
Assignee: Yukihiro Matsumoto
Category: core
Target version: 2.0.0


??????????????????????????????????????????String#version_compare ???追??????????????????
"2.6.18".version_compare("2.6.3") #=> 1
????使??????????

詳細???????? Gauche ??? gauche.version ???????? version-compare ??????????丸????????????????????????????????
??????????????????????? Gauche ?????????????
http://practical-scheme.net/gauche/man/gauche-refj_103.html

???????????????????????????????????????????????????????????????
Linux ??????????????????欲?????????????????????????????????????????????


-- 
http://redmine.ruby-lang.org