あいざわです。

bytesliceというメソッド名だとbytes liceと読めてしまってイケてないということのようですが、
aliasでbyte_sliceというメソッドを用意するのはいかがでしょうか。
同じような理由で名前が変だ(といわれそうな)メソッドに bytesize がありますのでこちらも
byte_size という alias を用意してはいかがでしょうか。
ZGlmZiAtLWdpdCBzdHJpbmcuYyBzdHJpbmcuYwppbmRleCA2MTcwM2E3Li45NTA0ZTUzIDEwMDY0
NAotLS0gc3RyaW5nLmMKKysrIHN0cmluZy5jCkBAIC03NzQyLDYgKzc3NDIsNyBAQCBJbml0X1N0
cmluZyh2b2lkKQogICAgIHJiX2RlZmluZV9tZXRob2QocmJfY1N0cmluZywgImxlbmd0aCIsIHJi
X3N0cl9sZW5ndGgsIDApOwogICAgIHJiX2RlZmluZV9tZXRob2QocmJfY1N0cmluZywgInNpemUi
LCByYl9zdHJfbGVuZ3RoLCAwKTsKICAgICByYl9kZWZpbmVfbWV0aG9kKHJiX2NTdHJpbmcsICJi
eXRlc2l6ZSIsIHJiX3N0cl9ieXRlc2l6ZSwgMCk7CisgICAgcmJfZGVmaW5lX21ldGhvZChyYl9j
U3RyaW5nLCAiYnl0ZV9zaXplIiwgcmJfc3RyX2J5dGVzaXplLCAwKTsKICAgICByYl9kZWZpbmVf
bWV0aG9kKHJiX2NTdHJpbmcsICJlbXB0eT8iLCByYl9zdHJfZW1wdHksIDApOwogICAgIHJiX2Rl
ZmluZV9tZXRob2QocmJfY1N0cmluZywgIj1+IiwgcmJfc3RyX21hdGNoLCAxKTsKICAgICByYl9k
ZWZpbmVfbWV0aG9kKHJiX2NTdHJpbmcsICJtYXRjaCIsIHJiX3N0cl9tYXRjaF9tLCAtMSk7CkBA
IC03NzU4LDYgKzc3NTksNyBAQCBJbml0X1N0cmluZyh2b2lkKQogICAgIHJiX2RlZmluZV9tZXRo
b2QocmJfY1N0cmluZywgImdldGJ5dGUiLCByYl9zdHJfZ2V0Ynl0ZSwgMSk7CiAgICAgcmJfZGVm
aW5lX21ldGhvZChyYl9jU3RyaW5nLCAic2V0Ynl0ZSIsIHJiX3N0cl9zZXRieXRlLCAyKTsKICAg
ICByYl9kZWZpbmVfbWV0aG9kKHJiX2NTdHJpbmcsICJieXRlc2xpY2UiLCByYl9zdHJfYnl0ZXNs
aWNlLCAtMSk7CisgICAgcmJfZGVmaW5lX21ldGhvZChyYl9jU3RyaW5nLCAiYnl0ZV9zbGljZSIs
IHJiX3N0cl9ieXRlc2xpY2UsIC0xKTsKIAogICAgIHJiX2RlZmluZV9tZXRob2QocmJfY1N0cmlu
ZywgInRvX2kiLCByYl9zdHJfdG9faSwgLTEpOwogICAgIHJiX2RlZmluZV9tZXRob2QocmJfY1N0
cmluZywgInRvX2YiLCByYl9zdHJfdG9fZiwgMCk7Cg==