2011年12月6日13:34 KOSAKI Motohiro <kosaki.motohiro / gmail.com>:

> あれ。同じ結果になるのはstaticにリンクしたときだけで、rubyはshared library使ってるから
> 意味があるような。
> 普通は開発者の手元にあるバージョンじゃなくて、使用者が実際に使ってるバージョンを知りたいはず。
> 想定用途をバグ回避のworkaround入れる用の追加バージョン情報取得とみるならば。

それはたしかに。

では、動的に取得するようにしてみました。

なお、Berkeley DB の db_version() は db.1.86 にはなくて、db-2.7.7 にあります。
その間は見つからなかったのですが、そこで何かあったらそのときに考えましょう。
-- 
[田中 哲][たなか あきら][Tanaka Akira]