高尾です。

コメントだけになってしましますが、

On 2011/11/01, at 1:18, Yui NARUSE wrote:
> r33603 で修正しました。
> File.expand_path 時の coderange 設定ミスのようです。
> ./ruby -e'p File.expand_path("あ").ascii_only?' #=> true なのが誤り

trunkにコミットされていることを確認しました。
これは1.9.3-p0にバックポートされますでしょうか。
(されるような気がしています。)

また、Redmineにて1.9.3へのバックポート対象を管理できたほうがいいかもしれないと思いました。