まつもと ゆきひろです

なんでこの二人には伝わらない。

In message "Re: [ruby-dev:44633] Re: Ruby 2.0 release plan"
    on Thu, 20 Oct 2011 12:24:10 +0900, "NARUSE, Yui" <naruse / airemix.jp> writes:

|比較的近い未来だと、2.0.0 の次をどうするかと、
|MVM が 2.0.0 に入らないとして、入った時どうなるのか、とか。

私は MVM について全容を把握しているわけじゃないんで、今それ
を決めろと言われても。ソース互換性があるらしいから TEENY で
いいんじゃないですか。

[ruby-dev:44619] で不満なら、あいざわさんの [ruby-dev:44636]
ではどうでしょう?

|卜部さんと同意見です。
|加えて、バージョン番号は実は soname や lib/ruby 下のファイル名などに影響したり、
|今どのくらいの非互換をつっこんでいいのかにも影響するので。

いや、そういうのがもうイヤなんですよ。なんでバージョン番号が
先になるのか。これ以上、バージョン番号なんてくだらないことで
進歩が遅くなるのはたくさんです。技術的にsonameが変える必要が
あれば、その要求を満たすようにバージョン番号を上げたらいいし、
非互換を突っ込みたくて、それをバージョンで明示したいなら上げ
たらいいじゃないですか。

リリースするたびに「このリリースはマーケティングの観点から
TEENYを上げるべきか、MINORを上げるべきか」って議論すればそれ
でいいじゃないかと思うんですが。

                                まつもと ゆきひろ /:|)