前田です。

2011年9月28日21:15 Kazuhiko <kazuhiko / fdiary.net>:
>> 1.9.[234]で仕様が違うという点については、どうせ$SAFEは2.0で削除すべきだ
>> と思うので、あんまり気にしなくてもいいんじゃないでしょうか。
>
> レンタルtDiaryの運営者としては、このissueそのものよりも↑こっちの方が気に
> なります。:)

$SAFEは他の処理系でまったく実装されていないですし、サンドボックスとしても
中途半端なので、根本的に見直した方がよいと思っています。
が、合意が得られているわけではないので、結局2.0でも残ってしまうかもしれません。

tDiaryのプラグインについては、本来Rubyのコードをユーザに記述させる必要ない
と思うのですが、互換性的に記述方法を変えるのは難しいのでしょうね。
記法がある程度限定されていれば、自前でパースして、Rubyのコードとしてではなく
プラグイン処理だけ実行できるかもしれませんが…。

-- 
Shugo Maeda