前田です。

2011年9月26日22:26 KOSAKI Motohiro <kosaki.motohiro / gmail.com>:
>> Yuguiさんが1.9.3ブランチにバックポートしてくださって、先ほどめでたく
>> 1.9.3RC1が出た今ころになって気づいて、ものすごく申し訳ないのです
>> が、$SAFE=3の時は動くけれど、$SAFE=4だと相変わらず失敗するようです。
(snip)
> r33328 で直ったようですが、1.9.3に入れますか?みなさんの意見が聞きたいです。
> 正直ぼくのなかでは重要度は微妙なんですけど、このままだた1.9.[234] でそれぞれ
> 仕様が違うという事態になるので、それもいかがなものかと思い悩んでいます。

アプリケーション側のworkaroundとしては、$SAFE >= 4のサンドボックス内で
使用を許可したい変換表を$SAFE == 0のときにあらかじめロードしておくとい
う手があるので、tDiaryのケースでそれが現実的な解となるかどうかが、一つの
判断材料ですね。

$SAFEが4以上の時はグローバルな状態の変更が禁止されるという原則があった
と思うんですが、このケースはそれに抵触しないのかなというのがちょっと気に
なります。影響は限定的なので実害はない気がするのですが。

1.9.[234]で仕様が違うという点については、どうせ$SAFEは2.0で削除すべきだ
と思うので、あんまり気にしなくてもいいんじゃないでしょうか。

-- 
Shugo Maeda