2011年7月26日8:45 KOSAKI Motohiro <kosaki.motohiro / gmail.com>:
> 逆に Debian 4.0 をperhapsに落とすことを提案します。Windowsのサービスパックだって要求ハードウェアのレベルが
> 上がったりするぐらいなんだからゆるされると思います。
> Debian 4.0は「誰も確認してないけど、非互換いれてないからたぶん動きます」という状態でこれはperhaps以外の何者でもないと思います。
>
> 5 or 6はSupport or Best-effortに入れるべきだと思うのですが、誰かメンテしてる人が必要だと思います。現在 Debian使ってる人は
> 誰なんでしょうか?なんかみんなUbuntuに移行してしまったイメージがあるのですが。

それは Debian のメンテナが決めることだと思います。
なお、どのバージョンをサポートしているか曖昧なプラットフォームも多いので、
Debian もそうした形になる可能性はありますね。

> それから、OpenSolarisはOracleの方針転換によりディストリごと消えたのでリストから削除したい。Solarisについてはメンテナが
> いるけれども、約1年放置されつづけたプラットフォームが先月メンテナがみつかったからサポートしてるぜ、ってのはあまりに
> 面の皮が厚すぎるので2.0 (1.9.4?)まではPerhapsにとどめる事を提案します。だって、1.9.3のリリースマネジメントで全然ケアしてなかったんですよ?

Best Effort/Perhaps は、がんばります/がんばりません の違いなので、
install すらできないとかでない限りいいんじゃないですかねぇ。
で、Solaris は現状そこまでボロボロではないと理解しています。
まぁ、この辺もメンテナの判断かと思います。

> あと、OS X Lionはllvm-gccでは動かない事が確認できているので、llvm-gccはダメだとどこかに書きたい。絶対バグレポートを
> 沢山貰うので、このURLでアナウンス済みじゃー。といいたい。

Supported Platforms のページに動かないことが確認されていてかつやる気のない環境の
リストでも作ればいいんですかね、というわけでとりあえず書いてみました。

http://redmine.ruby-lang.org/projects/ruby-19/wiki/SupportedPlatformsJa

-- 
NARUSE, Yui  <naruse / airemix.jp>