遠藤です。

2011年5月8日23:01 Shyouhei Urabe <shyouhei / ruby-lang.org>:
> というわけでmapなんだけど配列じゃなくてEnumeratorを返すmapの変種があ
> るといいとおもうのですがどうでしょうか。

賛成です。以下のようなコードを書くときいつも気になってました。

  big_ary.map {|x| ... }.max

ただ、map だけでなく、select や take にも適用できる convension
を決めるべきだと思います。


「遅延評価」の英語は、普通は lazy か delay だと思います。
rude というのを聞いたことがありません。ただいずれにしても 5 文字
以上の追加は長すぎるように思います。

遠藤はかつて -er (-or) の接尾辞を提案しました (つまり mapper) 。
http://d.hatena.ne.jp/ku-ma-me/20091111/p2

以下の方は _lz の接尾辞を提案されています。
https://github.com/antimon2/enumerable_lz/tree/master/lib/enumerable_lz


> いきなりmapの戻り値の型が変わるのでも私はいいですけど
> ちょっとやりすぎかとも思います。

2.0 でなら、これもいいと思います。

-- 
Yusuke Endoh <mame / tsg.ne.jp>