2010/12/7 Yusuke ENDOH <mame / tsg.ne.jp>:
> 2010年12月7日0:47 NARUSE, Yui <naruse / airemix.jp>:
>> (2010/12/07 0:34), Yusuke ENDOH wrote:
>>> まず確認ですが、
>>>
>>>    - ruby_1_9 は当分切らない (少なくとも 1.9.3 リリースまでは)
>>>    - trunk のブランチから次に出るリリースは 1.9.3
>>>    - 1.9.x 中で互換性は壊れない (キーワードの追加とかはまずない)
>>>      - 2.0 も compatible を目指すということですし
>>>
>>> というのは確定ということでよいでしょうか。
>>
>> 「1.9.x 中で互換性」の「互換性」を「後方互換性」にすれば理解通りです。
>
> ありがとうございます。ただ、この確認については authority (まつもとさん・
> Yugui さん) の言質が欲しいと思っています。

あそこでいう互換性は「後方互換性」という認識です。
* まつもとさんが言うには当分は後方互換性は壊れないということだそうです。この辺は私が決めることではないです。
* 後方互換性が決定的に壊れるときまで、ruby_1_9ブランチを切ってメンテナンスすることに意義を見いだしません。
  * 逆に壊れればその時はブランチを切るので、「1.9.x 中で(後方)互換性は壊れない」は保証します。
* よって後方互換性がtrunkで決定的に壊れることがない限り、次のtrunkからのリリースは1.9.3になります。

-- 
Yuki Sonoda (Yugui)
yugui / yugui.jp
http://yugui.jp