チケット #3638 が更新されました。 (by _ wanabe)


ワナベです。

>  パッチ拝見しました.
> 
>  話としては良いと思うのですが,マクロ名が一般的すぎて,ちょっと問題では
> ないかと思いました.

ありがとうございます。なるほど。

>  というのも,たとえば「CREF(cfp)」なんかは,すべての CREF がそのように
> アクセスできるのならそれでいいと思うのですが,そうでないこともあるのに,
> この一般的な名前はまずいのではないかと思います.
> 
>  そもそも,その辺の統一がとれていないという設計がまずいという気もします.

この例で言えば、CREF にアクセスできない時もある、ということがわかればよいのでしょうか。
であれば、たとえば CREF_OR_XX_OR_… のような名前はどうでしょうか。
ささださんのいう「統一がとれていないという設計」が一目瞭然になって
「『後で直す』コメント」的な意味合いを持たせられるのでは、と思います。
(個人的には設計がまずいとは思いませんが)

そこで改めて質問なのですが、

・「たとえば」ということでしたが、名前が一般的すぎるのは CREF() と ERRINFO() の
 二つ、という認識でよろしいでしょうか。それともまだありますでしょうか。

・上の質問と関連して、マクロで取り出される値にはどういった種類があるでしょうか。
 CREF() を例にとれば、CREF または SVAR が取り出されるという認識でよいでしょうか。
----------------------------------------
http://redmine.ruby-lang.org/issues/show/3638

----------------------------------------
http://redmine.ruby-lang.org