チケット #2727 が更新されました。 (by Yui NARUSE)


一応まとめまで。

これは gcc 4.4 の 32bit 版で発生する問題で、catch したところで落ちるのが特徴です。
踏む環境は例えば Ubuntu 9.10、Ubuntu 10.04、Fedora 11 (全て32bit) などになります。

Ruby 側としては、この問題は gcc のバグであって、特に回避策は入れない方針です。
----------------------------------------
http://redmine.ruby-lang.org/issues/show/2727

----------------------------------------
http://redmine.ruby-lang.org