まつもと ゆきひろです

In message "[ruby-dev:4186] UTF-8 patch for Ruby-1.2.1"
    on 99/01/16, Yoshida Masato <yoshidam / yoshidam.net> writes:

|よしだです
|
|Ruby が UTF-8 対応するのを待っていられなくて,不完全ながら
|UTF-8 に対応させてみました。

すばらしい.1.2系は安定版ですので,1.3系に取り込みます.
# こういうのがあると一気に進むなあ.

|対応していないのは
|
|  ・ 一部の正規表現 ('\w', '\W', '\b' など)
|  ・ 正規表現の文字コードオプション
|  ・ もともとマルチバイト化されていない機能 (tr, chop など)
|  ・ jcode.rb
|  ・ その他?
|
|です。('\w' は EUC や SJIS でも挙動不審のような?)

ええ.これは修正しました.1.2.1で反映されると思います.その
結果,1.3系では\w, \W, \bはUTF8にも対応します(と思います).

正規表現の文字コードオプションって /RE/u のようなのですよね.
これも対応させましょう.uって大丈夫なんだっけ.

                                まつもと ゆきひろ /:|)