遠藤です。

お返事ありがとうございます。

2010年3月26日10:54 Yugui <yugui / yugui.jp>:
> 2010/3/26 Yusuke Endoh <redmine / ruby-lang.org>:
>> サポート終了してしまいました。どうしましょう。
>>
>> 1) 1.9.1 はそのまま、1.9.2 では 5.0 に上げる
>> 2) 1.9.1(-pXXX) も 1.9.2 も 5.0 に上げる
>
> かなり悩ましいです。1.9.1の途中で変えるのは望ましくないし、一方メンテナンス終了してるディストリビューションだけってのもいまいちだからです。
> そこで、
> * 1.9.2は5.0に上げる
> * 1.9.1は4.0と5.0にする
> のを提案します。

それが理想だとは思いますので、反対はしません。

ただ、1.9.1 ブランチメンテナ (Yugui さん) のメンテナンスコストが
高まる気はします。Yugui さんは、もっと自分が楽になる方向に指針を
決めていいと思います。


>> また、supported platform について他に何か変更などの考えはあるでしょうか。
>> Snow Leopard とか。
>
> それと同じ理由で、私の環境はまだLeopardなのでこのままではSnow Leopardはperhapsになります。Snow
> Leopardで継続的ビルド環境を立ち上げてくださる方がいれば歓迎します。そうすればSnow
> Leopardをsupportedにすることも可能です。

質問の意図は、「best effort や perhaps に変更はあるか」でした。

supported platform を増やすのには、基本的には反対です。リリース
難易度が上がりますので。久しく (最低 1 年は) best effort として
メンテナンスされてきて、現在もメンテナがいて、今後も継続なメンテ
ナンスが期待できる platform なら、supported にしてもいいかも知れ
ません。


> 重要な話なので、詳しいことは一度考えをまとめてruby-coreに書きます。

お任せします。よろしくお願いします。

-- 
Yusuke ENDOH <mame / tsg.ne.jp>