遠藤です。

2010年1月31日0:51 Yukihiro Matsumoto <matz / ruby-lang.org>:
>
> |  Integer#[], Integer#size
> |
> |の名前を変えた方がよいんじゃない? って言いたいところですが...
> |どう見ても他のクラスの[], sizeと振る舞いが違いますしねぇ, duck type 的
> |にもイマイチな気がします.
>
> これらはduck typingという概念よりも古いですからねえ。今さら
> 変えられないとも思います。
>
> さらにいえば、duck typing的というならば、型チェックなどしては
> いけなくて、[ruby-core:27901]のようなエラーは許容すべきなんじゃ
> ないかと思います。


いしつかさんもまつもとさんも反対ということで、勝手に reject させて
頂きました。

http://redmine.ruby-lang.org/issues/show/2495

もし問題があったら reopen してください。

-- 
Yusuke ENDOH <mame / tsg.ne.jp>