まつもと ゆきひろです

In message "Re: [ruby-dev:40237] Re: [Bug:trunk] three bugs of Matrix::Scalar"
    on Fri, 29 Jan 2010 19:24:35 +0900, keiju / ishitsuka.com (石塚圭樹) writes:

|  Integer#[], Integer#size
|
|の名前を変えた方がよいんじゃない? って言いたいところですが...  
|どう見ても他のクラスの[], sizeと振る舞いが違いますしねぇ, duck type 的
|にもイマイチな気がします.

これらはduck typingという概念よりも古いですからねえ。今さら
変えられないとも思います。

さらにいえば、duck typing的というならば、型チェックなどしては
いけなくて、[ruby-core:27901]のようなエラーは許容すべきなんじゃ
ないかと思います。