Bug #2237: Interoperability between 1.8 and 1.9 through Marshal
http://redmine.ruby-lang.org/issues/show/2237

起票者: Yuki Sonoda
ステータス: Open, 優先度: Normal
カテゴリ: core, Target version: 1.9.x
ruby -v: ruby 1.9.2dev (2009-09-29 trunk 25144) [i386-darwin9.8.0]

当たり前といえばそうなんですが、ruby 1.9で拡張されたMarshalフォーマットをRuby 1.8が認識しません。
将来的に何か手立てを考えたいです。Marshalのバージョンアップに後から追随するためのものを配布するなり何なりの方策はないでしょうか。

 % ruby-trunk -v
 ruby 1.9.2dev (2009-09-29 trunk 25144) [i386-darwin9.8.0]
 % ruby18 -v
 ruby 1.8.7 (2009-06-12 patchlevel 174) [i686-darwin9]
 % ruby-trunk -e 'print Marshal.dump([:あ]*3)' | ruby18 -e 'p Marshal.load($<.read)'
 [:"\343\201\202", :E, :E]
 % ruby-trunk -e 'print Marshal.dump(["あ"]*3)' | ruby-trunk -e 'p Marshal.load($<.read)'
 ["あ", "あ", "あ"]


----------------------------------------
http://redmine.ruby-lang.org