チケット #2036 が更新されました。 (by 和弥 寺元)


寺元です。

xlc(8.0.0)コンパイラにて、ruby-1.8.7-p174をインストールしたところ
make testでエラーにならないでインストールできました。


$ ./configure --without-gcc

$ make

$ ./miniruby -e 'x=2.6.round; p x.class, "%.20f" % x'
Fixnum
"3.00000000000000000000"

% su
# make install
# exit

$ ruby -v
ruby 1.8.7 (2009-06-12 patchlevel 174) [powerpc-aix5.2.0.0]

----------------------------------------
http://redmine.ruby-lang.org/issues/show/2036

----------------------------------------
http://redmine.ruby-lang.org