まつもと ゆきひろです

In message "Re: [ruby-dev:39264] Re: Fwd: [redmine4ruby-lang:253] [Bug #1914] 	ruby-1.9.1-p243 failed to build from source on aix 5.3 with gcc 4.2.0"
    on Wed, 9 Sep 2009 02:48:23 +0900, Yutaka Kanemoto <kinpoco / gmail.com> writes:

|AIXでruby 1.9 を使う時の話がいくつかあがっているのですが、
|とりあえず最初に見つけたこれに調べたことを報告させていただきます。
|
|rubyのコードの中で、dln.cにAIX固有のコードがあります。
|おそらくですが、昔のAIXでdlopenがうまく動かなかったか、なかったときのものと思います。
|1.9では#1914,#2063,#2064のようなことがおきる一因になっています。
|
|というところで提案なのですが、このAIX固有のコードではなく、ほかのPlatformのように
|dlopenを使うように変更するというのはいかがでしょうか??
|最近のAIX(とりあえず5.2と5.3)では添付のパッチでmake testはパスしました。
|
|ほかにも課題はたくさんあるのですが、このパッチで上述の三つの問題は、
|とりあえず手元では解決します。

もう、古いAIXに対応する必要はないんではないでしょうか。
こちらでtrunkにコミットしておきます。

金本さんはコミット権欲しいですか?