成瀬です。

2009/09/08 13:09, Tietew wrote:
>> まぁ、IRI をサポートしようと思うと NFC や Punycode が必要になるので、
>> 現時点ではサポートしようよ!という話ではないです。
> 
> 一応、rubygemsに、libidnを使ったidn gemがあります。

今は標準添付ライブラリの URI の話なので、
URI が libidn 依存の gem に依存した場合、gem だけ添付しても
うれしくなく、しかも libidn は LGPL なのでこれごと添付もはばかられ。

というわけで、添付するとしたら idnkit でしょうかね。
http://www.nic.ad.jp/ja/tech/idn.html
http://www.sera.desuyo.net/idnkit/

-- 
NARUSE, Yui  <naruse / airemix.jp>