成瀬です。

Tanaka Akira wrote:
> In article <4A9E44DD.6050706 / airemix.jp>,
>   "NARUSE, Yui" <naruse / airemix.jp> writes:
> 
>> ふーむ、そうだとすると、そのようなメソッドが URI.escape と URI.encode を
>> 押さえてしまっているのはいやですねぇ。
>> 長期的には encodeURI あたりと置き換えたいところですが、
>> 1.9.2 で変えちゃうのはまずいかなぁ。
> 
> この類のメソッドが複数必要なら、それぞれがその機能を表現する
> メソッド名を持つべきなんじゃないですかねぇ。
> 
> だとすれば URI.escape と URI.encode という名前は機能を表現で
> きていないので使うべき名前ではなくて、そのうち削除予定という
> ことで警告を入れるあたりがいいんじゃないですか。

そうですね、とりあえず警告を出そうと思いますが、
異見のある方はいらっしゃいますか?

-- 
NARUSE, Yui  <naruse / airemix.jp>