Yukihiro Matsumoto wrote::
> まつもと ゆきひろです
> 
> In message "Re: [ruby-dev:38646] Re: [Feature: trunk] GC.stat"
>     on Tue, 16 Jun 2009 09:31:07 +0900, SASADA Koichi <ko1 / atdot.net> writes:
> 
> | slot の配列を heap,heap の配列を heaps ,でいいんでしたっけ.
> 
> gc.cではそういう名前になってます。
> 
> | そうすると,free_slot,live_slot (active_slot)は悪くないような.そも
> |そも heap が嫌って話?
> 
> 一般的にはheapというのはメモリ割り当てで切り出してくる領域全
> 体を指すのではないかという指摘だと思います。Gaucheの例でも
> (heapに)割り当てられたオブジェクトの数を返してますし。

 ちょっと考えたのですが,slot というのを,object_slot という形で明示す
れば,あまり間違いようがないと思うのですが,どうでしょう.

- active_object_slot: 生きてるオブジェクトが格納されている slot
- free_object_slot:   空き slot
- zombie_object_slot: ファイナライザ待ちオブジェクトの slot


 gc.c での heap の数(rb_objspace.heap.length)も,取りたいなぁ,と思い
始めたのですが,(heap を使用禁止だとすると)いい名前が思いつかない.

-- 
// SASADA Koichi at atdot dot net