ささだです.

 generator を 1.8 エッジで使ったらこんな感じで強制終了されました.


Linux ... 2.6.18-6-amd64 #1 SMP Thu Dec 25 21:08:54 UTC 2008 x86_64
GNU/Linux

$ /tmp/ruby_1_8/bin/ruby -ve "
  require 'generator'
  gen = Generator.new((0..600000))
  while gen.next?
    gen.next
  end
"
ruby 1.8.7p5000 (2009-02-25 revision 22633) [x86_64-linux]
/tmp/ruby_1_8/lib/ruby/1.8/generator.rb:188: warning: method redefined;
discarding old next
強制終了


 32bit Linux でも同様でした.

Linux vd 2.6.18-6-686 #1 SMP Sat Dec 27 09:31:05 UTC 2008 i686 GNU/Linux

ruby 1.8.7p5000 (2009-02-25 revision 20371) [i686-linux]
/tmp/ruby_1_8/lib/ruby/1.8/generator.rb:188: warning: method redefined;
discarding old next
Killed


-- 
// SASADA Koichi at atdot dot net