まつもと ゆきひろです

In message "Re: [ruby-dev:37928] Re: [Feature:trunk] with_index_from"
    on Fri, 6 Feb 2009 12:04:30 +0900, "Akinori MUSHA" <knu / iDaemons.org> writes:

| しかし、 each_with_index_from という名前は長すぎると思います。
|また each_with_index 自体、 Enumerator が導入された今となっては
|each.with_index よりも若干実行効率がよいことを除けば存在意義が
|薄いですね。
|
| ここは、 with_index にだけ引数を追加して each_with_index は
|そのままにしてはどうでしょう。
|
|StringIO.new("foo|bar|baz").each("|").with_index(1) { ... }
|
| ちょっと凝ったことをしたければ Enumerator 経由で行ってね、
|というスタンスは悪くはないと思います。

each_with_indexは放置。Enumerator#with_indexの方で手当てする
方に賛成します。が、現時点では簡潔なwith_index(1)にするのか、
より明確なwith_index_from(1)にするのかは決断できません。どっ
ちがよいでしょうねえ。