Bug #1115: $SAFE=1でのrequireがSecurityErrorになる
http://redmine.ruby-lang.org/issues/show/1115

起票者: Kazuhiro NISHIYAMA
ステータス: Open, 優先度: Normal
カテゴリ: core
ruby -v: ruby 1.9.1p0 (2009-02-02 revision 21960) [i686-linux]

[ruby-dev:37843]の件がredmineにチケットとして登録されていなかったので、登録します。

現在わかっている条件は以下の2つです。

1. *.soをrequireする。

% ruby-1.9.1 -ve '$SAFE=1;p require "zlib"'
ruby 1.9.1p0 (2009-02-02 revision 21960) [i686-linux]
-e:1:in `require': Insecure operation - require (SecurityError)
        from -e:1:in `<main>'
%

2. 何かgemをインストールした状態で何でもいいのでrequireする。

% ruby-1.9.1 -ve '$SAFE=1;p require "English"'
ruby 1.9.1p0 (2009-02-02 revision 21960) [i686-linux]
-e:1:in `require': Insecure operation - require (SecurityError)
        from -e:1:in `<main>'
%

何もgemをインストールしていなければ成功します。

% ruby-1.9.1 -ve '$SAFE=1;p require "English"'
ruby 1.9.1p0 (2009-02-02 revision 21960) [i686-linux]
true
%


----------------------------------------
http://redmine.ruby-lang.org