こんにちは、なかむら(う)です。

In message "[ruby-dev:37351] Re: [Feature #841] Object#self"
    on Dec.11,2008 00:04:33, <matz / ruby-lang.org> wrote:
> 前者はまったく必要性が理解できません。後者はselfという名前は
> ふさわしくないと思います。さらに言えばわかりやすさが増してな
> い(っていうかむしろ意図がわかりにくい)割にバイト数すら減って
> ないし。

意図のわかりやすさはともかく、+@にこの機能を持たせると、括弧
が省略できるときに &:+@ は {|a|a} より1バイト短くなります。

... gorubyに入れとくか。


それでは。
-- 
U.Nakamura <usa / garbagecollect.jp>