ささだです.

Kouhei Sutou wrote::
> Ruby/GLibでrb_thread_criticalを使っているのですが、
> rb_thread_criticalが1.9.1ではなくなっているため、ビルドでき
> ない状態になっています。
> 
> 1.9.1でも動くようにしたいのですが、1.9.1では、なにか別の
> rb_thread_critical相当のものがあるのでしょうか?
> Ruby/Tkでは単に無視しているだけのように見えるのですが、1.9.1
> では特に何もしなくてもよくなっているのでしょうか?

 Thread.critical 相当はないので,たとえば Mutex を利用してください.C
からは,rb_mutex_* で利用出来ます.

-- 
// SASADA Koichi at atdot dot net