--pgp-sign-Multipart_Thu_Jun__5_14:13:59_2008-1
Content-Type: text/plain; charset=ISO-2022-JP

At Thu, 5 Jun 2008 14:01:19 +0900,
okkez wrote:
> Ruby1.8.7 で Rails 2.0.2 が動きません。
> # 自分でビルドしたのと Debian のパッケージを試しました。
> 以下で再現すると思います。
>
> $ rails _2.0.2_ hoge
> $ cd hoge
> $ script/generate scaffold post title:string body:string published:boolean
> $ rake db:migrate
> $ script/server
>
> でウェブブラウザから
> http://localhost:3000/posts/new
> にアクセスすると Internal Server Error になります。
>
> Rails2.1.0 だと再現せず、きちんと動きます。
> また Ruby1.8.6 と Rails2.0.2 の組み合わせもきちんと動くのは確認済です。

 preview4後に適用した Marshal のバグ修正によって顕在化してしまった
delegate ライブラリのバグ(引数の実装漏れ)で、リリース直後に修正は
commitしています。

http://svn.ruby-lang.org/cgi-bin/viewvc.cgi/branches/ruby_1_8_7/lib/delegate.rb?r1=16732&r2=16756


 どこかのタイミングで 1.8.7-pN を出します。お急ぎの場合は ruby_1_8_7
ブランチをチェックアウトして使ってください。

--
Akinori MUSHA / http://akinori.org/

--pgp-sign-Multipart_Thu_Jun__5_14:13:59_2008-1
Content-Type: application/pgp-signature
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (FreeBSD)

iEYEABECAAYFAkhHdhcACgkQkgvvx5/Z4e47oACeOwaj4MO/QP1rRelBbEXyVFP6
CY0AmwXs5AiPS/IzfLE3mNPLN1b3SiEN
=Pxdv
-----END PGP SIGNATURE-----

--pgp-sign-Multipart_Thu_Jun__5_14:13:59_2008-1--