森脇です。

>>> I'm not sure what version that corresponds to offhand.  This version of thread.c should be safe:
>>>
>>>   http://svn.ruby-lang.org/cgi-bin/viewvc.cgi/branches/ruby_1_8/ext/thr...
>>>
>>> -mental
>> とあり、リポジトリ上で対策していることがうかがえます。
> 
> 最終的に1.8.6ブランチにバックポートされたのはr13495なので
> 2007/9/23 patchlevel 110です。
> 
> 追加しておくと、fastthreadの最新である1.0.1には最新版では修正済
> の問題が残っていますので、上記以上のバージョンにはインストールし
> ないでください。

まつもとさん中田さん、ありがとうございます。
現状のRubyで問題ないということで、安心しました。

では。

-- 
Daigo Moriwaki
beatles at sgtpepper dot net