> 実際的に重要な機能が Rational() という名前で固定されるのはクラスの定義
> として弱いと思うので、原さんに倣って Rational.convert 相当のものを用意
> して、Rational() はそちらに丸投げする構造にしようかと思います。

以上に加えて、new を reduce と同じにして、new まわりを少し整理したので
あたらしいのを置いておきます。

http://www.funaba.org/archive/nurat-0.0.3.tar.gz