まつもと ゆきひろです

In message "Re: [ruby-dev:31321] Re: Import RubyGems to Ruby 1.9"
    on Wed, 1 Aug 2007 14:33:42 +0900, Nobuyoshi Nakada <nobu / ruby-lang.org> writes:

|「パッケージングシステムの1つ」という位置づけであれば、「他のパッ
|ケージングシステム」も考えられるわけで、グローバルのrequireを銘々
|が直接置き換えるというのは望ましくないと思います。

|>   - I was hoping we could use rb_funcall to invoke a Kernel#require in
|>     require_libraries() rather than calling the C rb_require directly.
|>     Is this possible? (注: 中田さんよろしく)
|
|上で書いた理由から、できればこれは避けたいというのが個人的希望。

-r がrb_f_requireでなく、rb_funcall(ruby_top_self, :require, ..)
を呼ぶだけでも違うと思うんですが。そういう話じゃない?