けいじゅ@いしつかです.

In [ruby-dev:30932] the message: "[ruby-dev:30932] Re:
Integer#prime_division と Prime", on Jun/08 17:48(JST) TOYOFUKU
Chikanobu writes:

>  豊福です。

>  ps = (2..self) でよいという意味ですか? 

でした.

>2と3の倍数くらいは
>間引いた方が (大きな数).divmod(prime) を少しでも省けてよさそうな
>気がしますが。私は次のようなのを考えてました。
>
>    prime = 1
>    step = nil
>    loop do
>      if (step)
>        prime += step
>        step = 6 - step
>      else
>        case prime
>        when 1; prime = 2
>        when 2; prime = 3
>        when 3; prime = 5; step = 2
>        end
>      end

うーむ. こっちのほうが数倍早いですね.
こっちにさせてください.


__
---------------------------------------------------->> 石塚 圭樹 <<---
---------------------------------->> e-mail: keiju / ishitsuka.com <<---