At Fri, 13 Oct 2006 21:25:14 +0900,
I wrote:
>  あとは、 size() と name() はインスタンスメソッドとして存在すべき
> なのかよくわかりませんでしたが、互換性を考慮して残してあります。

 パラメータを取るアルゴリズムの場合、クラスではなくインスタンスで
持たないとダメですね。Digest 全体で採用しようと思います。

-- 
                     /
                    /__  __            Akinori.org / MUSHA.org
                   / )  )  ) )  /     FreeBSD.org / Ruby-lang.org
Akinori MUSHA aka / (_ /  ( (__(  @ iDaemons.org / and.or.jp

"Different eyes see different things,
    Different hearts beat on different strings --
       But there are times for you and me when all such things agree"