まつもと ゆきひろです

In message "[ruby-dev:2746] Re: return value of iterator File.open and Dir.open"
    on 98/05/26, Inaba Hiroto <inaba / st.rim.or.jp> writes:

|もし統一することにするならselfがいいような気がします。でも、「統一すべ
|き」かどうかは、わかりません。

そーですねー,もうちょっと考えてみましょう.

|今、Hashの[]メソッドに別名として(例えば)fetchを使えるようにし、このメ
|ソッドがイテレータとしてブロックを受け取れるようにし、これがHashの要素
|がなかった時に実行されその値が返るとすると、豊福さんが書いておられたハッ
|シュキーがなかった時のデフォルトが少し簡単に書けます。

それは良いアイディアですね.豊福さんの好みはどうもHashに状態
を持つ事のようですが,それはともかく採用しましょう.

                                まつもと ゆきひろ /:|)