前橋です。

From: NAGAI Hidetoshi <nagai / dumbo.ai.kyutech.ac.jp>
Subject: [ruby-dev:2711] cannot require tk.rb
Date: Wed, 20 May 1998 10:28:58 +0900

> しばらく version-up していなかった ruby-1.1b9_16 から
> 新しいものに上げようとしました.
> ...動きません.(;_;)
> 1.1b9_17 〜 22 すべてダメです.
> 
> まず,require 'tk' ですら,
> -----------------------------------------------------------
> /usr/local/lib/ruby/tk.rb:264: [BUG] Segmentation fault
> IOT trap/Abort (core dumped)
> -----------------------------------------------------------
> となってしまいます.

tcltklib をコンパイルするときに参照するヘッダファイルと、実際にリンクす
るライブラリのバージョンが食い違っているときにこれに似た現象が発生したこ
とがあります。複数のバージョンの tcl/tk が入っているということはないでしょ
うか?

ruby-1.1b9_16 以前の tcltklib は、tcl/tk のヘッダとライブラリでバージョ
ンが入り乱れていてもたいてい動いてしまうんです。