-v なときに ripper を require すると、次のように警告が出ます。

% ./ruby -v -rripper -e ''
ruby 1.9.0 (2005-09-06) [i686-linux]
/home/akr/ruby/head-ruby/lib/ruby/1.9/ripper/core.rb:395: warning: method redefined; discarding old on_do_block
/home/akr/ruby/head-ruby/lib/ruby/1.9/ripper/core.rb:827: warning: method redefined; discarding old on_lambda
/home/akr/ruby/head-ruby/lib/ruby/1.9/ripper/sexp.rb:72: warning: method redefined; discarding old on_lambda
/home/akr/ruby/head-ruby/lib/ruby/1.9/ripper/sexp.rb:93: warning: method redefined; discarding old on_lambda
-- 
[田中 哲][たなか あきら][Tanaka Akira]