山本です。

>「歴史的な事情」ですね.(^_^;
>最初に tile 拡張の wrapper を作成していた頃は,
>Tcl/Tk でのコマンド名が ::tbutton などであったので
>そのような名前にしてましたが,より新しいバージョンでは
>::ttk::button になったんですよね.
>treeview は ::tbutton の頃には存在しなかったので
>TTreeview にはなってないと.

うーん、そういうことですか。私は include Tk::Tile した時に
他のモジュールのクラスと競合しないように Tile の T が
ついているのかと思っていました。

>まぁ,確かに一貫性を欠くというのは言えそうですので,
>以下のような patch ではいかがでしょう?

このパッチですが、Scale として使っても WidgetClassName が TScale というのは
問題ないでしょうか?それは抜きにしても、一貫性をとるために冗長性が導入されて
しまうというのは、少なくとも私の手ではコミットしづらいものがあります。

個人的には TScale を Scale に変えて TScale を残さないというのが
すっきりする気がするのですが、1.8.2 のリリース時にすでに Tk::Tile::TButton
などが入ってるので難しいでしょうね・・・