山本です。

20 Apr 2005 付けの checkout から、install 前の runruby.rb を使った
ruby-tk の起動ができなくなっています。(install 後も動かないかどうかは確かめてません)

E:\ruby-cvs\bcc32>ruby19 -v s:\blade.rb
ruby 1.9.0 (2005-04-19) [i386-bccwin32]
E:/ruby-cvs/bcc32/.ext/tk/itemfont.rb:14: uninitialized constant TkTreatItemFont
 (NameError)
        from E:/ruby-cvs/bcc32/.ext/tk/itemconfig.rb:6:in `require'
        from E:/ruby-cvs/bcc32/.ext/tk/itemconfig.rb:6
        from E:/ruby-cvs/bcc32/.ext/tk/listbox.rb:5:in `require'
        from E:/ruby-cvs/bcc32/.ext/tk/listbox.rb:5
        from s:/blade.rb:47


Tue Apr 19 23:02:40 2005  Nobuyoshi Nakada  <nobu / ruby-lang.org>

	* eval.c (search_required): deal with features with path too.

	* intern.h (rb_file_expand_path): prototype.  fixed: [ruby-dev:26082]

Tue Apr 19 08:38:07 2005  Nobuyoshi Nakada  <nobu / ruby-lang.org>

	* eval.c (search_required, rb_require_safe): expand path in
	  rb_features.  [ruby-dev:26079]

	* file.c (rb_find_file_ext): return absolute path.

	* ext/extmk.rb: expand path for ext/**/extconf.rb.

	* eval.c (search_required): handle static linked extensions.


の何れかの変更が影響しているのだと思います。
他の extension は動くので、autoload が動かなくなっているのではないかと
思うのですが・・・

# ruby_1_8 の方は動きます。